Эксель посчитать количество слов в ячейке

Эксель посчитать количество слов в ячейке

Для подсчета количества слов в ячейке используем функции ДЛСТР() , СЖПРОБЕЛЫ() и ПОДСТАВИТЬ() .

Пусть ячейка A1 содержит текст « Желаю приятно провести время !».

Для подсчета в ней слов запишем формулу (см. файл примера )

= ЕСЛИ(ДЛСТР(СЖПРОБЕЛЫ(A1))=0;0; ДЛСТР(СЖПРОБЕЛЫ(A1))-ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))+1)

Формула возвращает значение 4, означающее, что в ячейке содержится четыре слова, разделенные пробелами. При этом не имеет значения, разделены ли слова несколькими пробелами, или слова начинаются или заканчиваются пробелами. Функция СЖПРОБЕЛЫ() удаляет лишние пробелы, пробелы в начале и в конце текста в ячейке.

Также формула проверяет есть ли полезная информация в ячейке: ДЛСТР(СЖПРОБЕЛЫ(A1))=0 .

Пользователи Microsoft Word знают, на сколько полезна возможность узнать количество слов в набранном тексте. Однако, пользуясь Excel, узнать количество слов в документе не возможно штатными средствами.

В этой статье мы разберем, как с помощью формул посчитать количество слов в одной или нескольких ячейках.

Как посчитать количество слов в ячейке Excel

Для подсчета количества слов в ячейке нам потребуются функции ДЛСТР и ПОДСТАВИТЬ . Формула для учета количества слов будет выглядеть так:

Используя эту формулу для любой ячейки, вы получите значение количества слов, находящихся в ней.

Как эта формула работает?

Прежде чем мы погрузимся в то, как работает формула, предлагаю поразмышлять.

Если мы составим обычное предложение из 8 слов, то их будут разделять 7 пробелов.

Это означает, что в любом предложении слов на один больше чем пробелов. То есть, для того, чтобы посчитать количество слов в предложении, нам нужно рассчитать количество пробелов и прибавить к этому числу один.

Соответственно, наша формула работает следующим образом:

  1. Функция ДЛСТР в первой части формулы подсчитывает количество символов в ячейке (с учетом пробелов)
  2. Во второй и третьей части формулы мы комбинируем функции ДЛСТР и ПОДСТАВИТЬ для подсчета количества символов в ячейке без пробелов
  3. Прибавляем к полученному значению число “один”

Если вы используете эту формулу для пустой ячейки, то результат вычисления будет равен единице.

Во избежание этого, я предлагаю использовать в дополнение две функции: ЕСЛИ и ЕПУСТО . Формула будет выглядеть так:

Читайте также:  Жпс трекеры для собак

Эти две функции проверяют, есть ли текст в ячейке или она пустая. Если в ячейке нет текста, формула вернет значение “ноль”.

Как посчитать количество слов в нескольких ячейках Excel

Теперь, перейдем на более сложный уровень.

Представим, что наша задача посчитать количество слов в нескольких ячейках.

Хорошая новость заключается в том, что мы будем использовать ту же формулу, что мы рассматривали на предыдущем примере, с небольшим дополнением:

=СУММПРОИЗВ(ДЛСТР(A1:A10)-ДЛСТР(ПОДСТАВИТЬ(A1:A10;” “;””))+1)

В указанной выше формуле А1:А10 это диапазон ячеек в рамках которого мы хотим посчитать количество слов.

Как эта формула работает?

Эта формула работает по тому же принципу, что и для подсчета количества слов в одной ячейке. Разница лишь в использовании функции СУММПРОИЗВ . Она помогает нам вычислить количество слов во всем массиве данных.

Всякий раз, когда вы вводите текст в ячейку или диапазон ячеек, эти методы позволяют посчитать количество слов.

Я надеюсь, что в будущем Excel получит штатную возможность для подсчета слов.

Уверен, эти приемы помогут вам стать лучше в Excel.

Описание функции

Функция =СЧЁТСИМВЛ(ТЕКСТ, СИМВОЛ) имеет два обязательных аргумента:

  • ТЕКСТ — Строка, в которой необходимо посчитать количество символов.
  • ШАБЛОН — Символ, который необходимо посчитать.

Если вы забыли синтаксис данной функции, вы всегда сможете вызвать формулу из выпадающего списка функций в надстройке.

Теперь к практике. Далее привожу множество примеров использования данной функции.

Пример 1

Посчитать количество пробелов в тексте.

Пример 2

Посчитать количество заданных символов.

Пример 3

Посчитать количество символов не обращая внимание на регистр.

Пример 4

Посчитать количество слов в тексте.

Пример 5

Посчитать количество слов в тексте не обращая внимания на двойные пробелы.

Пример 6

Посчитать количество всех символов в строке за исключением пробелов.

Читайте также:  Заточной станок геометрия отзывы

Альтернатива данной функции

Excel позволяет пользователям достичь правильного решения разными путями. Данная формула не исключение. Заменить данную функцию можно с помощью двух других: ДЛСТР и ПОДСТАВИТЬ. Чтобы определить количество заданного символа сначала определите длину всего текста функцией ДЛСТР, а затем отнимите от этого значения длину этого же текста, только с предварительно удаленными символами (которые вы ищите): =ДЛСТР(B13)-ДЛСТР(ПОДСТАВИТЬ(B13;" ";"")). В файле для скачивания приведены конкретные примеры.

Ссылка на основную публикацию
Что такое экранное время в ios
Экранное время – одна из лучших функций iOS 12, позволяющая следить за тем, как часто вы берёте в руки свой...
Что делать если отключился звук на компьютере
Мы зарегистрировали подозрительный трафик, исходящий из вашей сети. С помощью этой страницы мы сможем определить, что запросы отправляете именно вы,...
Что делать если полетели драйвера видеокарты
Распространенная ошибка в Windows 7 и реже в Windows 10 и 8 — сообщение «Видеодрайвер перестал отвечать и был успешно...
Что такое эмодзи клавиатура на телефоне
Современное общение сложно представить без мессенджеров, чатов и социальных сетей, но только текстом бывает сложно передать все эмоции. В этом...
Adblock detector