Чему равно значение переменной после выполнения алгоритма

Чему равно значение переменной после выполнения алгоритма

N Выходные значения A и C Блок-схема
1) 1, 7 2) 0, -4 3) 1, 3 4) 0, -5 5) зацикливание
1) 1, -1 2) 1, 0 3) 0, -1 4) 0, 0 5) зацикливание
1) 0, 0 2) 0, 1 3) -1, 1 4) -1, -1 5) зацикливание
1) 1, -1 2) 1, 0 3) 0, 0 4) 0, -1 5) зацикливание
1) 0, 0 2) 0, 2 3) 0, 1 4) -1, 0 5) зацикливание
1) 0, 0 2) 0, -2 3) 1, 0 4) 0, -1 5) зацикливание

22.1 Вычисленное по блок-схеме значение переменной F для входных данных 1,1,3 равно
1) 7 2) 3 3) 4 4) 5 5) 6

22.2 Вычисленное по блок-схеме значение переменной F для входных данных 3,3,1 равно
1) 4 2) 6 3) 5 4) 7 5) 3

22.3 Вычисленное по блок-схеме значение переменной F для входных данных 1,1,4 равно
1) 5 2) 6 3) 4 4) 7 5) 9

22.4 Вычисленное по блок-схеме значение переменной F для входных данных 1,1,4 равно
1) 7 2) 5 3) 6 4) 8 5) 9

22.5 Вычисленное по блок-схеме значение переменной F для входных данных 1,2,6 равно
1) 10 2) 7 3) 8 4) 11 5) 9

22.6 Вычисленное по блок-схеме значение переменной F для входных данных 1,2,6 равно
1) 3 2) 5 3) 6 4) 9 5) 8

22.7 Вычисленное по блок-схеме значение переменной F для входных данных 2,2,3 равно
1) 5 2) 6 3) 7 4) 9 5) 8

а31. Анализ заданного алгоритма.

1.1 Вычисляемое в программе

ШКОЛЬНЫЙ Аß QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1/6; S:=T нц для I от 1 до 99 Т:=Т/(2*I+2)/(2*I+3) S:=S+T кц вывод S кон DEFINT I T=1/6 : S=T FOR I=1 TO 99 Т=Т/(2*I+2У(2*I+3) S=S+T NEXT I PRINT S VAR I: INTEGER; S,T:REAL; BEGIN T:=1/6; S:=T; FOR I:=l TO 99 DO BEGIN Т:=Т/(2*I+2)/(2*I+3); S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.2 ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1; S:=T нц для I от 1 до 99 Т:=Т/(2*I+1)/(2*I) S:=S+T кц вывод S кон DEFINT I T=l :S=T FOR I=1 ТО 99 T=T/(2*I+1)/(2*I) S=S+T NEXT I PRINT S VAR I: INTEGER; S,T: REAL; BEGIN T:=1; S:=T; FOR I:=l TO 99 DO BEGIN T:=T/(2*I+ 1)/(2*I); S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.3 ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1/2; S:=T нц для I от 1 до 99 Т:=Т/(1+1/I)**2 S:=S+T кц вывод S кон DEFINT I Т=1/2 : S=Т FOR I=1 ТО 99 Т=Т/(1+1/I)^2 S=S+T NEXT I PRINT S VAR I: INTEGER; S,T: REAL; BEGIN T:=1/2; S:=T; FOR I:=1 TO 99 DO BEGIN T:=T/SQR(1+1/I); S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.4ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1; S:=T нц для I от 1 до 99 Т:=Т*(2*I-1)/(2*I+1) S:=S+T кц вывод S кон DEFINT I T=1 : S=T FOR I=1 ТО 99 Т=Т*(2*I-1)/(2*I+1) S=S+T NEXT I PRINT S VAR I: INTEGER; S, T: REAL; BEGIN T:=1; S:=T; FOR I:=l TO 99 DO BEGIN T:=T*(2*I-1)/(2*I+1); S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.5 ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1/3; S:=T нц для I от 1 до 99 Т:=Т*(2*I+1)/(2*I+3) S:=S+T кц вывод S кон DEFINT I Т=1/3 : S=Т FOR I=1 ТО 99 T=Т*(2*I+1)/(2*I+3) S=S+T NEXT I PRINT S VAR I: INTEGER; S,T: REAL; BEGIN T:=1/3; S:=T; FOR I:=l TO 99 DO BEGIN T:=T*(2*I+1)/(2*I+3); S:=S+T END; WRITE(S) END.
Читайте также:  Рисунок на тему моя родословная

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.6 ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т Т:=1/3; S:=T нц для I от 1 до 99 T:=T*(I+1)*(2*I+1)/ (2*I+3)/I S:=S+T кц вывод S кон DEFINT I Т=1/3 : S=Т FOR I=1 TO 99 Т=T*(I+1)*(2*I+1)/ (2*I+3)/I S=S + T NEXT I PRINT S VAR M,I: INTEGER; S,T: REAL; BEGIN T:=1/3; S:=T; FOR I:=l TO 99 DO BEGIN M:=2*I+1; T:=T*(I+1)*M/(M+2)/I; S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

1.7 ШК. АЯ QBASIC PASCAL
алг сумма(рез вещ S) нач цел I, вещ Т T:=1; S:=T нц для I от 1 до 99 T:=T*(I+1)*(2*I-1)/ (2*I+1)/I S:=S+T кц вывод S кон DEFINT I T=1 : S=T FOR I=1 ТО 99 Т=T*(I+1)*(2*I-1)/ (2*I+1)/I S=S+T NEXT I PRINT S VAR I: INTEGER; S,T: REAL; BEGIN T:=1; S:=T; FOR I:=1 TO 99 DO BEGIN T:=T*(I+1)*(2*I-l)/ (2*I+1)/I; S:=S+T END; WRITE(S) END.

значение суммы S соответствует формуле с номером

1) 2) 3) 4) 5)

В2. Определение значения выражения по элементам массива

По значениям элементов указанного массива определить значение выражения

N элементы массива выражение варианты ответа
F[1..6] = 6, 5, 4, 3, 2, 1 F[ F[ F[3] ] ] — F[ F[2] — F[4] ] .
B[1..6] = 12, 10, 8, 6, 4, 2 B[ 2*B[6] + div( B[3], B[5] ) ] 1) 4; 2) 2; 3) 8; 4) 12; 5) 3
G[1..5] = a, b, a+b, 2a-b, a-3b G[ mod(15,a)] — G[a-8] при a=12, b=8 .
S[1..6] = 32, 16, 8, 4, 2, 1 S[S[6]] + div( S[2], S[4] ) .
А[1..6] = 2, 4, 6, 5, 3, 1 А[ А[ А[1] ] ] + А[ А[ А[2] ] ] .
Q[1..4] = 3, 1, 4, 3 Q[ Q[2] +2] — Q[ 2*Q[1] -3 ] .
H[1..4] = 1, 3, 4, 5 H[1] -H[-2 + H[3]] + H[H[4] — H[1]] .
p[1..5] = 1, -1, 5, 2, 4 p[1] * p[3 ] — p[ 2*p[2] + p[ p[5] — p[2] ] ] .
T[1..5] = 36, 8, 4, 2, 1 T[ T[5] ] + mod( T[3], T[2] ) .
p[1..4] = 2a-b, a+2b, 4-a, b-3 p[ b-p[a+b]] + p[a+p[a-2b]-p[2b]] при a=3, b=1 1) 0; 2) 1; 3)-2; 4) 2; 5) Ни один из отв. 1-4
p[1..5] = 1, 4, 4, 6, 1 p[ p[2] div ( p[1] + p[5] ) +2] — p[ Pred( p[2] ) +Round( Exp( Ln(2) )) ] 1) 5; 2) 1; 3) 2; 4) 4; 5) Ни один из отв. 1-4
В[1..6] = 12, 10, 8, 6, 4, 2 B[ 2*B[6] + div( B[3], B[5] )] .
E[1..4] = 8, 6, 4, 2 mod( E[8-E[3] ], E[1]-E[2] ) .
G[1..5] = a, b, a-b, a-2b, a-3b G[ mod(a,4) ] при a=7, b=2 .
A[1..6] = 2, 4, 6, 5, 3, 1 A[ A[ A(3)] ] ] — A[ A[ A(4) ] ] ] .
H[1..4] = 2, 6, 1, 7 H[1]-H[ 4-H[3] ]+H[ H[2]-H[1] ] .
p[1..5 ]= 1, 3, 5, 2, 4 p[1]*p[3] — p[3*p[2] — p[ p[3]-p[4] ] ] .
T[1..5] = 32, 8, 4, 2, 1 T[ T[5] ] + div( T[1], ( T[2] -T[4] ) ) .

19. Задан массив A[5,5]:

Вычислите результат выполнения фрагмента алгоритма B:=0 нцдля i от 1 до 5 B:=B+A[i,6-i] кц
Читайте также:  Как сделать архив на сайте

20. Одномерный массив, содержащий 10 элементов, заполняется по следующему закону:

A[1]=1; A[2]=x; A[i]=2*x*A[i-1]-A[i-2], где i=3,4. 10.

Значение A[5] при x=1 будет равно .

B3. Определение результата работы программы

Определить значение переменной k после выполнения фрагмента программы.

N фрагмент программы N фрагмент программы
1.1 k:=0; нц для i:=1 до 1000 | если mod(i, 3)=1 и mod(i, 5)=2 | | то k:=k+1 | все кц 1.2 k:=0; нц для i:=1 до 1000 | если mod(i, 3)=1 или div(i, 4)=200 | | то k:=k+1 кц
1.3 k:=1 нц для i:=1 до 1000 | если mod(i, 4)=1 и не mod(i, 5)=2 | | то k:=k+1 | все кц 1.4 k:=0 нц для i:=1 до 1000 | если mod(i, 3)=1 или mod(i, 3)=2 | | то k:=k+1 | все кц
1.5 k:=0 нц для i:=1 до 1000 | если не div(i, 3)=100 и mod(i, 5)=2 | | то k:=k+1 | все кц 1.6 k:=1 нц для i:=1 до 1000 | если не div(i, 300)=3 и mod(i, 3)=1 | | то k:=k+1 | все кц
1.7 k:=0 нц для i:=1 до 1000 | если не div(i, 100)=3 и mod(i, 5)=2 | | то k:=k+1 | все кц 1.8 k:=0 нц для i:=1 до 1000 | если mod(i, 4)=1 или mod(i, 5)=2 | | то k:=k+1 | все кц
1.9 k:=1; нц для i:=1 до 1000 | если mod (i, 3) =1 или mod (i, 4) =3 | | то k:=k+1 | все кц

После выполнения фрагмента алгоритма переменная k приняла указанное значение. Определить минимальное целое N, при котором это возможно.

Последнее изменение этой страницы: 2016-08-15; Нарушение авторского права страницы

Дан фрагмент программы, обрабатывающий массив А из 10 элементов:

Бейсик Python

for i in range(1, 11):

Алгоритмический язык Паскаль

нц для i от 1 до 10

for i := 1 to 10 do

if A[i] = A[j] then j := i;

Чему будет равно значение переменной s после выполнения этого алгоритма?

3) индексу элемента, равного первому, и имеющему наибольший индекс

4) индексу элемента, равного последнему, и имеющему наименьший индекс

Изначально элемент a[j]=a[1]. Условие цикла говорит нам о том, что если какой-то элемент а[i] массива А совпадает с первым элементом этого массива, то индексу j присваивается значение индекса i. Т. к. цикл пробегает все значения i в порядке увеличения, то последним значением j станет наибольшее значение индекса i такое, что a[i]=a[1]. Это значение совпадёт со значением переменной s после выполнения алгоритма.

Правильный ответ указан под номером 3.

Дан фрагмент программы, обрабатывающий двухмерный массив A размером nxn.

Бейсик Python

В этом фрагменте:

1) упорядочивается первая строка массива по убыванию

2) упорядочивается первый столбец массива по убыванию

3) заменяются элементы k-ого столбца таблицы

4) заменяются элементы k-ой строки таблицы

Обратим внимание, что в двойном цикле переменная i изменяется от 1 до n-1, а j – от 1 до n (на 1 шаг больше). Это означает, что с элементом a[j,1] будут по очереди сравниваться все элементы столбца 1, кроме последнего. Они выстротся от самого большого до самого маленького сверху вниз, т.е. по убыванию.

Но чтобы выбрать правильный ответ, можно было рассмотреть данный фрагмент программы:

Эта операция меняет местами два элемента первого столбца, а значит все изменения происходят только в нём. Вариант ответа, в котором фигурирует только первый столбец, указан под номером 2.

Читайте также:  Don t starve комиксы на русском

Правильный ответ указан под номером 2.

В программе описан одномерный целочисленный массив A с индексами от 1 до 10. Ниже представлен фрагмент этой программы, в котором значения элементов массива сначала задаются, а затем меняются.

Бейсик Python

for i in range(1, 11):

for i in range(1, 11):

Паскаль Алгоритмический язык

for i : = 1 to 10

for i : = 1 to 10 do begin

нц для i от 1 до 10

нц для i от 1 до 10

Чему будут равны элементы этого массива?

1) 1 6 11 16 21 23 18 13 8 3

2) 3 8 13 18 23 28 33 38 43 48

3) 48 43 38 33 28 23 18 13 8 3

4) 1 6 11 16 21 26 31 36 41 46

Первый цикл, заполняем массив:

Второй цикл, меняем значение элементов:

i=1: k = a[1] — 2 = 3, a[11-1] = a[10] = 3,

i=2: k = a[2] — 2 = 8, a[11-2] = a[9] = 8,

i=6: k = a[6] — 2 = 21, a[11-6] = a[5] = 21 (здесь и далее используются уже изменённые элементы, а не исходные),

i=7: k = a[7] — 2 = 16, a[11-7] = a[4] = 16,

i=10: k = a[10] — 2 = 3 — 2 = 1, a[1] = 1.

Поэтому в результате выполнени программы элементы массива будут равны: 1, 6, 11, 16, 21, 23, 18, 13, 8, 3.

Правильный ответ указан под номером 1.

В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже представлен фрагмент одной и той же программы, записанный на разных языках программирования, обрабатывающей данный массив:

Бейсик Паскаль

IF A(i) > z THEN s = s + 1

for i: = 0 to n do

Си++ Алгоритмический язык Python

for i in range(0, n+1):

Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов массива?

1) Минимальному элементу в массиве A

2) Количеству элементов массива A, больших последнего элемента массива

3) Индексу последнего элемента массива А, который меньше A[0]

4) Количеству элементов массива A, меньших последнего элемента массива

Переменой z присваивается значение последнего элемента.

Внутри цикла все элементы массива сравниваются с последним, при этом если элемент больше последнего, то переменная s увеличивается на 1. Если в массиве x элементов больше последнего, то s примет значение, равное x, т. е. станет равным количеству элементов массива A, больших последнего элемента массива.

Правильный ответ указан под номером 2.

Ниже приведён фрагмент программы, записанный на четырёх языках программирования.

Массив A одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до n.

Бейсик Паскаль

Чему будет равно значение переменной s после выполнения данного фрагмента программы?

1) минимальному элементу в массиве A

2) индексу минимального элемента в массиве A (наименьшему из таких индексов, если минимальных элементов несколько)

3) индексу минимального элемента в массиве A (наибольшему из таких индексов, если минимальных элементов несколько)

4) количеству элементов, равных минимальному в массиве A

В данной программе реализуется алгоритм поиска наименьшего элемента массива. Переменной s присваивается индекс этого элемента. Следовательно, значение переменной s после выполнения данного фрагмента программы будет равно индексу минимального элемента в массиве A (наименьшему из таких индексов, если минимальных элементов несколько).

Эмм. Тут s постоянно переписывается на 6 же. N не меняется. Наверняка s = 6 будет всегда

Если на человеческий переводить, то
var s, i, j, N:integer;

begin
s:=0;
N:=5;
for i:=1 to N do
for j:=1 to i do
s:= N + 1;
writeln(s);

Ссылка на основную публикацию
Фотографии купе в поезде
Интересный фотоотчет о поездке на одном из первых рейсов двухэтажных поездов. Смотрим далее, как все устроено внутри таких двухэтажных вагонов...
Уравнение окружности в полярных координатах
Определение: замкнутая плоская кривая, все точки которой одинаково удалены от данной точки (центра О), лежащей в той же плоскости, что...
Уравнение пучка прямых проходящих через точку
Совокупность прямых, проходящих через некоторую точку, называется пучком прямых с центром в этой точке. Если и - уравнения двух пересекающихся...
Фотография с самым большим разрешением в мире
Представляем вашему вниманию нашу подборку самых больших фотографий в мире. Для их просмотра вам будет необходим FlashPlayer. Его можно скачать...
Adblock detector